mirror of
https://github.com/larstvei/nix-config.git
synced 2024-11-26 00:48:30 +00:00
85 lines
1.7 KiB
Nix
85 lines
1.7 KiB
Nix
{ pkgs, lib, ... }:
|
|
{
|
|
|
|
fonts.packages = import ./fonts.nix { inherit pkgs; };
|
|
|
|
users.users."larstvei".home = "/Users/larstvei";
|
|
|
|
programs.fish.enable = true;
|
|
|
|
system.activationScripts.postActivation.text = ''
|
|
# Set the default shell as fish for the user. MacOS doesn't do this like nixOS does
|
|
sudo chsh -s ${lib.getBin pkgs.fish}/bin/fish larstvei
|
|
'';
|
|
|
|
networking.hostName = "larstvei-macbookpro";
|
|
|
|
system = {
|
|
stateVersion = 4;
|
|
|
|
keyboard = {
|
|
enableKeyMapping = true;
|
|
remapCapsLockToControl = true;
|
|
};
|
|
defaults = {
|
|
screencapture = {
|
|
location = "/tmp";
|
|
};
|
|
dock = {
|
|
autohide = true;
|
|
showhidden = true;
|
|
mru-spaces = false;
|
|
};
|
|
finder = {
|
|
AppleShowAllExtensions = true;
|
|
QuitMenuItem = true;
|
|
FXEnableExtensionChangeWarning = true;
|
|
};
|
|
|
|
NSGlobalDomain = {
|
|
AppleKeyboardUIMode = 3;
|
|
ApplePressAndHoldEnabled = false;
|
|
AppleFontSmoothing = 1;
|
|
_HIHideMenuBar = true;
|
|
InitialKeyRepeat = 15;
|
|
KeyRepeat = 1;
|
|
"com.apple.mouse.tapBehavior" = 1;
|
|
"com.apple.swipescrolldirection" = true;
|
|
};
|
|
};
|
|
};
|
|
|
|
homebrew = {
|
|
enable = true;
|
|
onActivation = {
|
|
# autoUpdate = true;
|
|
upgrade = true;
|
|
cleanup = "uninstall";
|
|
};
|
|
taps = [
|
|
"homebrew/cask"
|
|
"homebrew/cask-versions"
|
|
];
|
|
casks = [
|
|
"amethyst"
|
|
"arc"
|
|
"chatgpt"
|
|
"docker"
|
|
"dropbox"
|
|
"google-chrome"
|
|
"iina"
|
|
"karabiner-elements"
|
|
"obs"
|
|
"ollama"
|
|
"processing"
|
|
"raycast"
|
|
"remarkable"
|
|
"signal"
|
|
"skim"
|
|
"supercollider"
|
|
"utm"
|
|
"zoom"
|
|
];
|
|
};
|
|
}
|