nix-config/hosts/nixos-intel-mbp/configuration.nix
2024-10-06 23:56:35 +02:00

27 lines
530 B
Nix

{ config, pkgs, lib, ... }:
{
networking.hostName = "larstvei-nixos";
time.timeZone = "Europe/Oslo";
i18n = {
defaultLocale = "en_US.UTF-8";
supportedLocales = [ "en_US.UTF-8" "nb_NO.UTF-8" ];
};
users.users.larstvei = {
isNormalUser = true;
home = "/home/larstvei";
extraGroups = [ "wheel" "networkmanager" ];
shell = pkgs.fish;
};
services = {
# Enable NetworkManager
networkmanager.enable = true;
};
# System state version
system.stateVersion = lib.mkDefault "24.11";
}